RC India
Welcome Guest, please login or register.
 
Pages: [1]   Go Down
0 Members and 1 Guest are viewing this topic. Topic Tools Topic Tools 
Read
« on: November 08, 2016, 02:05:20 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011




hello guys,
               Yesterday I completed my new build with martian220 frame, details below.


FRAME : Martian 220
FC       : X RACER 3.1 (SPI)
ESC     : XS30A - Blheli DYS
MOTOR : COBRA CP 2205 2300KV
PROPS: DALPROPS 5045X3 V2
PDB     : dual bec pdb
VTX,MINIM MICRO OSD, HS1177
PIDS: left at default - using multishot 8K/2K

The ISSUE is that yaw seems to be twitchy, i tried many PIDS but dint seem to work, I did save the black box for the troubleshooting. So while the test all i do is arm the quad, change to acro, just lift off minimal or no inputs on pitch/roll and yaw and then land. But if you see the yaw gyro seems to think its yawing . And the motor was bit warm on higer side after just <1 min test. Attached the DBLACKBOX log file. The gyro is not doing it on the other axis.And from log i can see the motor speed is very much varying due to the yaw gyro. Can you please help in find whats the issue? Or is it a faulty gyro ?  Huh? Huh?

Black Box link - https://drive.google.com/open?id=0B_xCImR-u7L4cnFQUE1WRm1OdE0

@satyagupta ,@vibranthobbies, @Himadri Roy, @Sagnik, @bhaveshsangani

thanks


gyro1.jpg
New Martian220 build - YAW/GYRO issues
* gyro1.jpg (52.22 KB, 800x450 - viewed 261 times.)
This post has 1 more images(s)/attachment(s). Please login or register to view them.
« Last Edit: November 08, 2016, 05:35:30 PM by merin_83 » Logged

thanks,
merin
 

Read
« Reply #1 on: November 08, 2016, 02:30:04 PM »
Gulzaar
Multirotor maniac
Heli Lover
Senior Member
***

Reputation Power: 4 
Gulzaar has no influence.
Offline Offline

City: Surat
State: Gujarat
RC Skills: Advanced
Posts: 169
Join Date: Feb, 2015



What do you mean twitchy? Does it yaw by itself? Have you set board orientation correctly in BF?
Logged

ZMRX210, QAV210
http://fpvfrenzy.com
YouTube Channel: https://www.youtube.com/channel/UCpmH-nJComfpkn3F6-PHXCw

Sponsored by Quadkopters for IDRL S01E01
 

Read
« Reply #2 on: November 08, 2016, 02:35:23 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011


Re:

Yes it clicks very small angle in yaw axis...  And after less than a minute flight..  Motors considerably warm..  Yes orientation is correct... If you see motor in black box it's varying much

Sent from my Redmi Note 3 using Tapatalk
Logged

thanks,
merin
 

Read
« Reply #3 on: November 08, 2016, 05:06:40 PM »
Swapnil
Plane Lover
Forum Hero

*****

Reputation Power: 20 
Swapnil barely matters.Swapnil barely matters.
Offline Offline

City: Pune
State: Maharashtra
RC Skills: Beginner
Posts: 1755
Join Date: May, 2010

Retreat, Hell!



...  And after less than a minute flight..  Motors considerably warm..
...

That could be because those motors draw close to 20A with 5x4.5x3 props.

I'd like to build a similar quad. What is the total weight of your setup?
Logged
 

Read
« Reply #4 on: November 08, 2016, 05:14:02 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



...  And after less than a minute flight..  Motors considerably warm..
...

That could be because the motors draw close to 20A with 5x4.5x3 props. I'd like to build a similar quad. What is the total weight of your setup?

yes that could be one reason for the heat, but if you see the blackbox log, the motor is constantly fluctuating values, my other quads used to be more or less stable if i was just hovering with no other inputs.

And i was just hovering inside room, 2-3 ft high. So it definetly wont be drawing that much amps.
Logged

thanks,
merin
 

Read
« Reply #5 on: November 08, 2016, 05:20:54 PM »
Swapnil
Plane Lover
Forum Hero

*****

Reputation Power: 20 
Swapnil barely matters.Swapnil barely matters.
Offline Offline

City: Pune
State: Maharashtra
RC Skills: Beginner
Posts: 1755
Join Date: May, 2010

Retreat, Hell!



Oh, okay. The pictures you posted are very blurry, I couldn't read anything.

I'll be building my first 250 soon. Which LiPo are you using and what is the AUW of this setup?
Logged
 

Read
« Reply #6 on: November 08, 2016, 05:30:33 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



AUW is 561g with 4s lipo, its the bonka 1300mah 75c lipo. Have attached a new photo of quad in 1st post.
Logged

thanks,
merin
 

Read
« Reply #7 on: November 08, 2016, 05:48:10 PM »
Swapnil
Plane Lover
Forum Hero

*****

Reputation Power: 20 
Swapnil barely matters.Swapnil barely matters.
Offline Offline

City: Pune
State: Maharashtra
RC Skills: Beginner
Posts: 1755
Join Date: May, 2010

Retreat, Hell!



The prop data chart for those motors shows a max. draw of 19.52A with 5x4.5 props on 4s. Isn't it a bit risky with 5x4.5x3? Wouldn't the motors easily cross the max. allowed Amp rating during, say, a thrust punch?
Logged
 

Read
« Reply #8 on: November 08, 2016, 06:39:42 PM »
ashimda
Plane Lover
Forum Hero
*****

Reputation Power: 8 
ashimda has no influence.
Offline Offline

City: kolkata
State: West Bengal
RC Skills: Beginner
Posts: 590
Join Date: Nov, 2013



Just curious, what radio are you using?

Ashim.
Logged
 

Read
« Reply #9 on: November 08, 2016, 07:05:04 PM »
pravesh736
Car Lover
Forum Hero

*****

Reputation Power: 9 
pravesh736 has no influence.
Offline Offline

City: bangalore
State: Karnataka
RC Skills: Advanced
Posts: 706
Join Date: Feb, 2011

Gorkha tech



Soft mount ur fc, yaw twitch is also due to improper powersupply so check ur 5v line or add an lc filter.
Logged
 

Read
« Reply #10 on: November 08, 2016, 07:43:23 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



Soft mount ur fc, yaw twitch is also due to improper powersupply so check ur 5v line or add an lc filter.


yeah, will try a different bec and see, also planning to remount the FC, as this martian had one more tray above FC so we can mount rx ....
Logged

thanks,
merin
 

Read
« Reply #11 on: November 08, 2016, 07:51:12 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



Just curious, what radio are you using?

Ashim.

9xr pro with frsky djt module, i have set deadband to 15 on yaw and 5 on other channel.
Logged

thanks,
merin
 

Read
« Reply #12 on: November 08, 2016, 08:15:36 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



The prop data chart for those motors shows a max. draw of 19.52A with 5x4.5 props on 4s. Isn't it a bit risky with 5x4.5x3? Wouldn't the motors easily cross the max. allowed Amp rating during, say, a thrust punch?
[/quoti dont think its 19,,,
here is the chart

100%   Thrust (g)      Current (A)   
Prop Tested:   Max(g)   Avg Max(g)*   Max (A)   Avg Max(A)*

HQProp 5x4x3GF   1243   1223   111.20   26.84
Logged

thanks,
merin
 

Read
« Reply #13 on: November 09, 2016, 02:05:11 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



Guys today, i removed the fc mount, and then just kept the build clean, no FPV also, but still its there, then i checked the motor vibration, seems like motor 1 has small vibration and motor 2 has more from the motors tab, attached video of same ...

youtube like of test below



Please let me know your suggestions
Logged

thanks,
merin
 

Read
« Reply #14 on: November 09, 2016, 07:47:47 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



Today I removed the X racer 3.1 and mounted 2.1, seems like the yaw noice faded away.... dont seems to exist...

And here is the black box link .. https://drive.google.com/file/d/0B_xCImR-u7L4MmVac3JBSzRNWm8/view?usp=sharing

So i guess found the real issue ?


xracer 2.1 - black box.jpg
Re: New Martian220 build - YAW/GYRO issues - UPDATE
* xracer 2.1 - black box.jpg (30.49 KB, 800x450 - viewed 245 times.)
Logged

thanks,
merin
 

Read
« Reply #15 on: November 22, 2016, 07:06:22 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



Guys, finally am getting a replacement, Kumaran from RCH had worked with Vendor FPVmodal and they agreed to replace the board X Racer 3.1  Hats Off thanks RCH
Logged

thanks,
merin
 

Read
« Reply #16 on: November 29, 2016, 06:32:28 PM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



Today I got the replacement, it works perfect and no noise, no tuning WoW. Issue solved.
Logged

thanks,
merin
 

Read
« Reply #17 on: November 30, 2016, 02:23:40 PM »
kn8alpha
Plane Lover
Senior Member
***

Reputation Power: 2 
kn8alpha has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Advanced
Posts: 162
Join Date: Feb, 2016



That's great.. I would've suspected the ESC or it's firmware or a bum bearing on motor2, both of which could've been confirmed using a swap test.
Any clues what was wrong with the FC? The gyro chip or something else? Doesn't the motor test from PC bypass the gyro sensor and just control ESCs directly? If thats the case the FC output on motor 2 is somehow bad.
Logged
 

Read
« Reply #18 on: December 01, 2016, 10:29:19 AM »
merin_83
Heli Lover
Senior Member
***

Reputation Power: 3 
merin_83 has no influence.
Offline Offline

City: Bangalore
State: Karnataka
RC Skills: Intermediate
Posts: 164
Join Date: Aug, 2011



That's great.. I would've suspected the ESC or it's firmware or a bum bearing on motor2, both of which could've been confirmed using a swap test.
Any clues what was wrong with the FC? The gyro chip or something else? Doesn't the motor test from PC bypass the gyro sensor and just control ESCs directly? If thats the case the FC output on motor 2 is somehow bad.
I dint suspect esc...  As it flew perfect when fc was swapped...  Dono which part in fc

Sent from my Redmi Note 3 using Tapatalk
Logged

thanks,
merin
 

Pages: [1]   Go Up
Jump to:  

Related Topics
Subject Started by Replies Views Last post
Issues with PM Quota « 1 2  All »
RC India Forum
anwar 28 11727 Last post August 21, 2011, 05:28:59 AM
by anwar
HK-250GT Build and Issues « 1 2  All »
Helis
gbisht 30 15552 Last post May 31, 2012, 10:24:59 AM
by dheerajjuneja
Gyro for sale - GWS PG-03 Piezo Gyro
For Sale
anandp 3 2471 Last post February 07, 2013, 02:28:43 PM
by kanna
Su-37 Build - First build issues
Electric Planes
dheerajjuneja 16 8522 Last post April 08, 2013, 06:34:02 PM
by dheerajjuneja
Separating trade issues from aero issues
RC India Forum
K K Iyer 5 7135 Last post September 08, 2016, 08:28:23 PM
by K K Iyer