RC India
Welcome Guest, please login or register.
 
Pages: [1]   Go Down
0 Members and 1 Guest are viewing this topic. Topic Tools Topic Tools 
Read
« on: October 27, 2015, 10:34:27 AM »
ghoshatanu56
Plane Lover
Senior Member
***

Reputation Power: 3 
ghoshatanu56 has no influence.
Online Online

City: Kolkata
State: West Bengal
RC Skills: Beginner
Posts: 114
Join Date: Jul, 2011




So I bought a multiwii from robokits.in
i received it yesterday
but thats it.since that time i am having problems uploading sketch to the board
i receive message
stk500v2Receivemessage():timeout
no matter how much i try i get the same error
i burned the bootloader afresh and still the same
i checked for any faults in the ftdi line
what i found was there were two 219ohm resistors in each tx and rx line
now i am asking the board members for suggestion

Untitled.jpg
Problem uploading sketch to Multiwii AIO pro
* Untitled.jpg (48.84 KB, 800x450 - viewed 117 times.)
Logged
 

Read
« Reply #1 on: October 27, 2015, 11:53:26 AM »
sundaram
FAN OF FPV FLYING, AERIAL PHOTOGRAPHY & MICRO RC
Plane Lover
Forum Hero

*****

Reputation Power: 38 
sundaram is working their way up.sundaram is working their way up.sundaram is working their way up.
Offline Offline

City: Lucknow
State: Uttar Pradesh
RC Skills: Advanced
Posts: 3366
Join Date: Nov, 2009



Are you sure the USB Com port created for AIO pro is Com 4?Huh? After you plug in the AIO pro board wait for the drivers to install and com port to be created. only after installation of drivers open the Arduino program and under tools and Seriel port tab you will find a fresh com port numbered in 60s select that com port to load.
Logged

 

Read
« Reply #2 on: October 27, 2015, 03:30:07 PM »
ghoshatanu56
Plane Lover
Senior Member
***

Reputation Power: 3 
ghoshatanu56 has no influence.
Online Online

City: Kolkata
State: West Bengal
RC Skills: Beginner
Posts: 114
Join Date: Jul, 2011



Sundaram. Sir thanks for the reply.
I see the com port 4 only when i plug in the board. So i guessed that it is the correct port.
Logged
 

Read
« Reply #3 on: October 27, 2015, 05:55:37 PM »
Darshan for multirotors
Well now it flies!!
Heli Lover
Forum Hero
*****

Reputation Power: 11 
Darshan for multirotors has no influence.
Offline Offline

City: Mumbai
State: Maharashtra
RC Skills: Beginner
Posts: 855
Join Date: Feb, 2015



go to device manager on your pc and see the correct port on which your board is hooked
Logged

put your heart in flying and flying will never leave your heart
 

Read
« Reply #4 on: October 27, 2015, 07:05:13 PM »
sundaram
FAN OF FPV FLYING, AERIAL PHOTOGRAPHY & MICRO RC
Plane Lover
Forum Hero

*****

Reputation Power: 38 
sundaram is working their way up.sundaram is working their way up.sundaram is working their way up.
Offline Offline

City: Lucknow
State: Uttar Pradesh
RC Skills: Advanced
Posts: 3366
Join Date: Nov, 2009



Yes in that case very likely it is.
Logged

 

Read
« Reply #5 on: October 27, 2015, 07:14:16 PM »
SK1701
Heli Lover
Forum Hero

*****

Reputation Power: 11 
SK1701 has no influence.
Offline Offline

City: Montreal/ Bangalore
State: OUTSIDE INDIA
RC Skills: Intermediate
Posts: 884
Join Date: Oct, 2014

set acc_hardware = 1



What have you selected as the programmer and what programmer are you using? I'm not familiar with Multiwii but whatever little I know of Arduino might be useful.
Logged

FrSky Taranis X9D+
RS2206 Karpet Stretch
Oomph Carpet
Furibee X215 Pro
XK K110
S800 Flying Wing
www.facebook.com/FPVRacingBangalore/
 

Read
« Reply #6 on: October 27, 2015, 07:16:55 PM »
ghoshatanu56
Plane Lover
Senior Member
***

Reputation Power: 3 
ghoshatanu56 has no influence.
Online Online

City: Kolkata
State: West Bengal
RC Skills: Beginner
Posts: 114
Join Date: Jul, 2011



@SK1701
I am using the onboard  ftdi for programming. And i used usbasp for burning the bootloader.
Thanks in advance
Logged
 

Read
« Reply #7 on: October 27, 2015, 08:52:15 PM »
saikat
Plane Lover
Forum Hero
*****

Reputation Power: 14 
saikat has no influence.
Offline Offline

City: Tezpur
State: Assam
RC Skills: Intermediate
Posts: 1078
Join Date: Jul, 2009



what bootloader have you flashed ?
have you flashed thru the IDE ?

is your sketch compiling without any errors ?

try uploading a simple blink sketch and see ifyou can blink some leds

upload the blink using the usbasp and post the results  - and then we can try other things
Logged
 

Read
« Reply #8 on: October 27, 2015, 08:56:15 PM »
ghoshatanu56
Plane Lover
Senior Member
***

Reputation Power: 3 
ghoshatanu56 has no influence.
Online Online

City: Kolkata
State: West Bengal
RC Skills: Beginner
Posts: 114
Join Date: Jul, 2011



I burned the stk500boot_v2_mega2560.hex.found in the arduino folder. I used the arvdudess. I have tried the blink sketch. But it gives the same error.
Logged
 

Read
« Reply #9 on: October 27, 2015, 09:47:06 PM »
saikat
Plane Lover
Forum Hero
*****

Reputation Power: 14 
saikat has no influence.
Offline Offline

City: Tezpur
State: Assam
RC Skills: Intermediate
Posts: 1078
Join Date: Jul, 2009



try buring the bootloader from the ide -

open the arduino interface , select the board and then select the burn bootloader option
Logged
 

Read
« Reply #10 on: October 27, 2015, 09:53:12 PM »
saikat
Plane Lover
Forum Hero
*****

Reputation Power: 14 
saikat has no influence.
Offline Offline

City: Tezpur
State: Assam
RC Skills: Intermediate
Posts: 1078
Join Date: Jul, 2009



also check out the following link

http://electronics.stackexchange.com/questions/7769/how-to-burn-arduino-mega-2560-bootloader


somewhere in the middle - there is a discussion of the variant of avrdue used.

see if that will solve.

Logged
 

Read
« Reply #11 on: October 30, 2015, 01:52:46 PM »
ghoshatanu56
Plane Lover
Senior Member
***

Reputation Power: 3 
ghoshatanu56 has no influence.
Online Online

City: Kolkata
State: West Bengal
RC Skills: Beginner
Posts: 114
Join Date: Jul, 2011



Ok. So i was able to upload the multiwii sktech. But there seems to be a strange problem. I am able to upload only one sketch after the bootloader is burned into the mcu. After i upload one sketch if i try to upload another one. It gives the same error
Logged
 

Pages: [1]   Go Up
Jump to:  

Related Topics
Subject Started by Replies Views Last post
uploading video
RC India Forum
rajsigma 4 4390 Last post April 21, 2014, 10:37:26 AM
by sundaram
How to test a reciever for problem and how to fix any problem.
Electric Power
me-my-parts 11 5840 Last post January 09, 2010, 11:48:33 PM
by jerry
crius multiwii SE v2.0 arming problem(need help)
Multirotors
Dk 6 2305 Last post July 15, 2013, 10:01:49 PM
by Dk
Multiwii help
Multirotors
multiwiihelpreqd 22 4199 Last post July 25, 2014, 06:54:05 PM
by devangflyer
Uploading photos
Fuel and Engines
Aeroresurrect 5 1662 Last post December 14, 2017, 10:30:44 AM
by Aeroresurrect